Turning Signals - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-15-2007, 09:57   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 6
Turning Signals

2000 Exp, 164,000 miles
I lost both turning signals at the same time but my Harzard lights/flasher works?

Any ideas?
Flasher modules or something called a multiswitch?
Rando is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2007, 20:23   #2 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,706
Re: Turning Signals

Check fuses first. Also the flasher fuse. There is usually 2, one for hazzards, one for turn signals. And as you stated, the multifunction switch. Do the lights on the instrument panel light up, but the lights don't flash? Or, no lights at all?
thefonz is offline   Reply With Quote
Old 08-20-2007, 15:11   #3 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 1
Re: Turning Signals

hey guys, not trying to steal this post, but I have a 2005 Expedition with signal problems...I'm getting a very fast left signal on the dash, side view mirror, and front left...but on the back left, I have no signal and no brake light...right side is fine on everything...I checked the two fuses that the manual indicates as controling signals/brake lights, but they are okay...the light also appears okay, at least the filaments aren't blown/broken on the lamp...I'm a novice, any ideas what this might be?
jmmck is offline   Reply With Quote
Old 08-20-2007, 18:58   #4 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,706
Re: Turning Signals

Swap the bulbs to the other side to be sure 100% they are good. Check for power to the bulb socket. Check grounds.
thefonz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:52.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.