Vibration in 2005 Expedition - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-18-06, 09:18 PM
Posts: n/a
confused Vibration in 2005 Expedition

I have a 2005 expedition that out of the blue began vibrating when I start slowing down to come to a stop. The vibration is felt in the drivers seat in the back and legs. It feels as if the vehicle is going to stall. The dealer service center says there are no error codes and there is nothing wrong with the car, they say what I am feeling is normal. NOT! Has anybody else had this problem? Also where can I find TSB information?
Sponsored Links
post #2 of 2 (permalink) Old 03-02-06, 07:30 PM
Registered User
Join Date: Jan 2006
Location: Tioga, LA, USA
Posts: 148
Lightbulb Re: Vibration in 2005 Expedition

Feels like it's going to stall? Does it make any noises, or does the tach do anything weird? I've had 2003 Expedition, 1999 F150 (basically same), and currently a 2006 Expedition that all started shaking when the brakes were applied. I've come to 2 conclusions with these 3 vehicles: They don't allign the vehicles at the factory anymore (get it alligned when you buy one). And, the brake pads and rotors they are using now are CRAP! Not to mention the tires (since the lawsuit). Both Expeditions came with Continental SUV tires on them, and they are absolute trash! There's nothing you can do to get them to last or perform properly. I had the supposed "exploding tires" on an Explorer during the lawsuit...There was nothing wrong with those tires! Just FYI, I keep tires max inflated (check every week), and rotate them every 5K mi. Do this and keep your vehicle alligned, and your tires should last.

Write back if there's more to this story, or if you need more/other assistance.
redneckf150 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome