93 explorer pulling WAY left when turning left - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Suspension | Wheels&Tires | Brakes Sponsored by: Discount Tire Direct

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-02-06, 01:58 AM Thread Starter
Registered User
 
Join Date: May 2006
Posts: 2
Exclamation 93 explorer pulling WAY left when turning left

i just had my powersteering replaced i think they put the wrong one in? at first i thought maybe front bearings were tighened to much. but those were rechecked and ok. it feels like my steering wheel is hanging up sometimes when turning left and trying to straighten out wheel it POPS as im trying to slightly bring it right. it also seems to have a rubbing,humming,too tight sound . help!!!!!

snakeladyd is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-04-06, 04:07 AM
Life begins at 100km/h
 
EasyEA's Avatar
 
Join Date: Sep 2003
Location: Brisbane-Queensland
Posts: 23
Re: 93 explorer pulling WAY left when turning left

is it with the brakes on?

..............................................................................................
1997 EL Fairmont Ghia
Sleeper (170rwkw)
No exterior/interior mods, hehe
EasyEA is offline  
post #3 of 5 (permalink) Old 05-04-06, 10:15 AM Thread Starter
Registered User
 
Join Date: May 2006
Posts: 2
Re: 93 explorer pulling WAY left when turning left

no only when i turn left....now i have a horrible hummmm that gets louder depending on my speed
snakeladyd is offline  
post #4 of 5 (permalink) Old 07-07-06, 06:20 PM
Registered User
 
Join Date: Jul 2006
Posts: 1
Re: 93 explorer pulling WAY left when turning left

maybe your differential is twisted a little. It happen to me one time, and it was my rear
pachangibiri is offline  
post #5 of 5 (permalink) Old 07-07-06, 06:54 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: 93 explorer pulling WAY left when turning left

Sounds like a front U-Joint siezed causing the "POP" and binding.
Johnny Mullet is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome