Faulty Brake Lamp switch on EF - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Suspension | Wheels&Tires | Brakes Sponsored by: Discount Tire Direct

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-04-2002, 18:35   #1 (permalink)
Registered User
 
Join Date: Dec 2001
Posts: 698
Faulty Brake Lamp switch on EF

Hi guys.
My brake lamps have stopped working because of the Brake light switch, mounted on the Brake pedal.
The switch seems to work, but the way it is mounted on the brake pedal is very very loose.
It seems like the thing is almost going to fall off.

Anyway I was wondering if anyone has had any problems with these switches, or if anyone knows how these things should be mounted properly.

(I tried checking the EF workshop manual, and it has nothing on the brake switch !)

Any help would be greatly appreciated !

Cheers
Matt
Xyphoid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-04-2002, 19:47   #2 (permalink)
Shh i'm huntin more power
 
Jase_ELXR8's Avatar
 
Join Date: Jul 2001
Location: Melbourne
Posts: 1,764
Matt, it mounts onto the pin on the pedal. It actually works by the movement in arm from the booster on the pedal to switch on. The swtich will still work, but because it only moves ever so slightly when intalled properly the contacts inside burn. You can get replacement ones from bursons now, it's very common....
Jase_ELXR8 is offline   Reply With Quote
Old 04-04-2002, 22:01   #3 (permalink)
Registered User
 
Join Date: Feb 2002
Location: Melbourne
Posts: 35
I have had 3 replacement stop light switches on my 95 EF falcon, during its 215,000 kms, which is currently showing on the clock. How pathetic is that!
SimonH is offline   Reply With Quote
Old 04-04-2002, 23:25   #4 (permalink)
Registered User
 
Join Date: Dec 2001
Posts: 698
Bugger !
I am not impressed !
Oh well, does anyone know huch much these blighters are from Ford.

Jase_ELXR8 - I have never heard of Bursons ? Is that some sort of dealer, or someone like Super Cheap/Repco

Anyway, Thankyou for your help !
Looks like Ill be going to City Ford Tommorow Morning to get myself a new switch, (and a few other things)

Cheers
Matt
Xyphoid is offline   Reply With Quote
Old 04-05-2002, 05:12   #5 (permalink)
Australian EF2 Member
 
Join Date: Nov 2001
Location: Melbourne
Posts: 19
Replaced the brake lamp switch in my EF at around 80,000 km ... $45.00 installed at Ford dealership ... mechanic/auto elec said very common, thousands were replaced under warranty

Burson's are a parts shop ... much like repco
Blue EF2 is offline   Reply With Quote
Old 04-05-2002, 07:52   #6 (permalink)
Ex Member
 
Fairlane Boy's Avatar
 
Join Date: Nov 2001
Location: Perth
Posts: 717
Also had mine replaced under warranty on my Nf2

Didnt even notice it wasnt working either.

only symptom was sometimes the cruse control would take a second or two disengage when foot put on the brakes.

been replaced also on my brothers AU to, looks like its still not been solved

maybe they should have a brake light relay, rather than having them switched by the pedal switch, or is it allready like that ?
__________________
Best wishes
Fairlane Boy is offline   Reply With Quote
Old 04-05-2002, 17:43   #7 (permalink)
Future BA XR6T Pilot
 
krusic's Avatar
 
Join Date: Dec 2001
Location: Geelong, Victoria
Posts: 161
I just replaced mine about 2 months ago, I think that the switch was around $20 - $25 from the dealer and I fitted it myself, took about 10 minutes and i'm not great at working on cars. Saved about $20 for an autoelectrician to do the job.

Stephen
__________________
Now accepting donations towards a BA XR6 T U R B O
krusic is offline   Reply With Quote
Old 04-05-2002, 22:58   #8 (permalink)
Registered User
 
Rastus's Avatar
 
Join Date: May 2001
Location: Ballarat, Victoria
Age: 42
Posts: 1,395
Quote:
Originally posted by Fairlane Boy
Didnt even notice it wasnt working either.
only symptom was sometimes the cruse control would take a second or two disengage when foot put on the brakes.
Yep, same here on my EF Ghia and my brothers EL Fairmont.
I didn't even realise that I had no brake lights. All I knew is that I really had to mash the brake pedal hard to switch off the cruise.
Russell.
Rastus is offline   Reply With Quote
Old 04-07-2002, 23:49   #9 (permalink)
T5 Expert Operator
 
XR_Strider_GuY's Avatar
 
Join Date: Apr 2001
Location: 3Fb Skunk Works(JXR01 Dev)
Age: 34
Posts: 6,542
Yeap yeap, got mine replaced around the 130k mark. Seems to still be working on mine now. Costed something like $30 fitted.

Seems there a pretty crap design. Looks like the switch on the EL is about to go as well.
__________________
Motor May 2001 Quote: "Believe it or not, there are actually a bunch of weirdos out there who reckon a six cylinder is the dux gutz. Bugger it: I'm one of them" :s5

AUII Late Ed XR6 HP T5 Venom- Full Tickford Body Kit, 17in Wheels, Herrod Bi-plane Spoiler, Momo Steer/Gear, T-Series Interior Options, Premium Stereo and a very light-tuned 4.0L I6

(FPV-Tickford Club of NSW Member and Co-Founding Member of 3FB Inc, Ford Forums Food Bandits)
XR_Strider_GuY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing AU Centre Mount Brake Lamp AUForte Suspension | Wheels&Tires | Brakes 18 05-26-2003 07:34
Putting the Brakes on the Boss RPO83 FPV & Tickford Forum 11 01-28-2003 14:59
EF brake switches - I hate you honer Suspension | Wheels&Tires | Brakes 3 11-22-2002 15:01
EF Manifold Conversion (again!) Martin General Tech 19 08-22-2002 03:29
EF brake upgrade? mattyc Suspension | Wheels&Tires | Brakes 6 04-14-2002 23:27

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.