NF rear airbags not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Suspension | Wheels&Tires | Brakes Sponsored by: Discount Tire Direct

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-14-2004, 21:28   #1 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 31
Posts: 6
NF rear airbags not working

Hope someone can help me with this one. The rear suspension has decided that it doesn't want to engage the compressor and as a result the rear is in the lowermost position. I pressed the drivers door courtesy light switch to get it to do the self diagnosis and the "check susp" light came on. Not flashing, it just turned on and didn't go away until you turn the ignition off again. Any help with this would be greatly appreciated. Cheers.
Hodgie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2004, 21:36   #2 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: NF rear airbags not working

check the fuse possibly, otherwise the compressor sounds not functional, they are real simple though and pulling them apart is not all that complicated, even though they are listed as 'non' servicable, i like SLS and am keeping mine, most people will tell you to ditch the SLS though.
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 12-14-2004, 21:46   #3 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 31
Posts: 6
Re: NF rear airbags not working

Cheers. I was starting to think it could have been the switch in the back that activates the compressor. Didn't even think of just trying the fuse . Compressor itself was rebuilt 3 months ago.
Hodgie is offline   Reply With Quote
Old 12-14-2004, 21:54   #4 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: NF rear airbags not working

The switch has one plug to it, is easily removed, and unless a solder joint has gone dry in the module, there is not much that can go wrong inside it, I pulled mine apart before i rebuilt my compressor.
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 12-15-2004, 00:05   #5 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 31
Posts: 6
Re: NF rear airbags not working

Might take the switch off and take a quick look. Maybe one of the plugs has come loose. Oh well, food for thought. I'm interstate at the moment so when I get back at the end of January I'll give everything the once over. Will keep you updated. Cheers.
Hodgie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lowering my NF Fairlane.....urgent help required! BALISTC Suspension | Wheels&Tires | Brakes 5 09-27-2004 02:19
Eu:mazda6 Mps: The Ultimate Zoom-zoom Saloon Stacy94PGT Mazda Forum 0 09-23-2004 08:00
Attention SR Balcon (BA) Owners - Question re hole in rear bumper chris Australian Falcons 9 09-23-2004 02:15
Shelby Cobraís New Bite: 605 Horsepower RPO83 Ford Mustang Forum 8 02-05-2004 22:30
2005 S-type At A Glance RPO83 Ford Worldwide News 0 01-05-2004 17:32

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.