Somethings Wrong!? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Suspension | Wheels&Tires | Brakes Sponsored by: Discount Tire Direct

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-19-05, 06:57 PM Thread Starter
75xbgt351
 
Join Date: Jan 2005
Location: Western Australia
Age: 27
Posts: 13
frown Somethings Wrong!?

Hello all I have a problem with the brakes on my xb coupe........The brakes dont work when you put them on it makes a hissing noise and the engine starts getting rough but only when the brakes are on.Any Ideas??? Thanks

75xbgt351 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-19-05, 07:06 PM
Registered User
 
Ranger04's Avatar
 
Join Date: Jan 2005
Posts: 280
Re: Somethings Wrong!?

A hissing noise usually indicates a leak in a vacuum booster. You could have melted, detached or just old hoses. You will be hearing vacuum hiss from these, and likely have a less than optimal running motor under braking as you are indicating.
Ranger04 is offline  
post #3 of 5 (permalink) Old 01-19-05, 07:19 PM
Can't wait for Winton...
 
outback_ute's Avatar
 
Join Date: Jul 2003
Location: Victoria
Posts: 2,759
Re: Somethings Wrong!?

Also the brakes would take a LOT more effort without the booster, which would explain them not seeming to work.
outback_ute is offline  
post #4 of 5 (permalink) Old 01-19-05, 08:20 PM
Officially Bored with 347
 
svo347's Avatar
 
Join Date: Jul 2001
Location: Perth West Oz
Age: 43
Posts: 3,585
Re: Somethings Wrong!?

Put your foot hard on the brake pedal, start the car if its working properly the pedal should drop abit, if not the guys here have mentioned your problem, cracked hose ,it maybe have come off or the diaphram maybe leaking

FORD.... "POWER TO THE PEOPLE"...

Member of the "TKTDSGM " Group..
svo347 is offline  
post #5 of 5 (permalink) Old 01-20-05, 05:32 PM Thread Starter
75xbgt351
 
Join Date: Jan 2005
Location: Western Australia
Age: 27
Posts: 13
Re: Somethings Wrong!?

Ok Thanks Guys. :]
75xbgt351 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
wrong place at the wrong time Noddy The Pub 9 07-10-04 04:47 AM
Wrong, wrong, wrong, wrong, wrong, wrong, wrong, wrong!!! Genebaby The Pub 44 06-24-04 05:44 AM
Somethings wrong ?? HELP! crowbar Inline 6 Tech 9 10-09-03 02:01 AM
Whats wrong with Fords in NASCAR? LunaticSVT Ford Racing Across the Globe 10 10-02-03 08:29 PM
GOT SPARK! Now what's wrong with the timing? Sundeep General Tech 18 05-08-03 10:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome