Somethings Wrong!? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Suspension | Wheels&Tires | Brakes Sponsored by: Discount Tire Direct

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-19-2005, 18:57   #1 (permalink)
75xbgt351
 
Join Date: Jan 2005
Location: Western Australia
Age: 25
Posts: 13
frown Somethings Wrong!?

Hello all I have a problem with the brakes on my xb coupe........The brakes dont work when you put them on it makes a hissing noise and the engine starts getting rough but only when the brakes are on.Any Ideas??? Thanks
75xbgt351 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2005, 19:06   #2 (permalink)
Registered User
 
Ranger04's Avatar
 
Join Date: Jan 2005
Posts: 280
Re: Somethings Wrong!?

A hissing noise usually indicates a leak in a vacuum booster. You could have melted, detached or just old hoses. You will be hearing vacuum hiss from these, and likely have a less than optimal running motor under braking as you are indicating.
Ranger04 is offline   Reply With Quote
Old 01-19-2005, 19:19   #3 (permalink)
Can't wait for Winton...
 
outback_ute's Avatar
 
Join Date: Jul 2003
Location: Victoria
Posts: 2,759
Re: Somethings Wrong!?

Also the brakes would take a LOT more effort without the booster, which would explain them not seeming to work.
outback_ute is offline   Reply With Quote
Old 01-19-2005, 20:20   #4 (permalink)
Officially Bored with 347
 
svo347's Avatar
 
Join Date: Jul 2001
Location: Perth West Oz
Age: 41
Posts: 3,585
Re: Somethings Wrong!?

Put your foot hard on the brake pedal, start the car if its working properly the pedal should drop abit, if not the guys here have mentioned your problem, cracked hose ,it maybe have come off or the diaphram maybe leaking
__________________
FORD.... "POWER TO THE PEOPLE"...

Member of the "TKTDSGM " Group..
svo347 is offline   Reply With Quote
Old 01-20-2005, 17:32   #5 (permalink)
75xbgt351
 
Join Date: Jan 2005
Location: Western Australia
Age: 25
Posts: 13
Re: Somethings Wrong!?

Ok Thanks Guys. :]
75xbgt351 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Suspension | Wheels&Tires | Brakes



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
wrong place at the wrong time Noddy The Pub 9 07-10-2004 04:47
Wrong, wrong, wrong, wrong, wrong, wrong, wrong, wrong!!! Genebaby The Pub 44 06-24-2004 05:44
Somethings wrong ?? HELP! crowbar Inline 6 Tech 9 10-09-2003 02:01
Whats wrong with Fords in NASCAR? LunaticSVT Ford Racing Across the Globe 10 10-02-2003 20:29
GOT SPARK! Now what's wrong with the timing? Sundeep General Tech 18 05-08-2003 22:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.