03 Windstar HELP! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-17-08, 07:20 AM Thread Starter
Registered User
 
Join Date: Apr 2008
Posts: 1
Question 03 Windstar HELP!

I have an 03 Windstar Limited and just had the 60,000 mile service done (which included the fuel filter replacement). Since then, from time to time I get a "fuel error" message in the display on the dashboard. It usually comes on when accelerating, but sometimes while cruising.. but then sometimes not at all for about 2 weeks. Anyone know what the "fuel error" means or what could be causing it?

Thanks!

03Windstar is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-23-08, 01:39 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 03 Windstar HELP!

If you got the service done at a dealer I'd take it back and have them fix the problem as the problem originated from the service they performed. They don't charge the big bucks for nothing!

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome