03 windstar transmission problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-2005, 09:54   #1 (permalink)
Registered User
 
Join Date: Jul 2005
Posts: 1
03 windstar transmission problem

I have an 03 windstar that has really been a problem lately. Front springs, altenator, air conditioner, power steering pump, and brakes have all needed repair, with only 40,000 miles on vehicle. This morning I got in and started the van, and the transmission would not go into gear. It holds in park, but nothing happens when I shift into reverse or any forward gear. I drove in with no problems the night before! Anybody have any ideas?
marklmarvin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2005, 20:31   #2 (permalink)
Registered User
 
Join Date: Sep 2002
Location: ohio
Posts: 8
Re: 03 windstar transmission problem

Blessings,
I pray you have an extended warranty!
Get it fixed with warranty and the get rid of it as soon as you can blink an eye!
hallsound is offline   Reply With Quote
Old 04-01-2006, 00:32   #3 (permalink)
Registered User
 
Join Date: Apr 2006
Posts: 4
Re: 03 windstar transmission problem

Personally I don't agree with hallsound on this one.

The problem is probably the shift linkage. I would guess that during one of the previous repairs a wire was removed/loosened or you may have simply blown a fuse.

I'm not in easy access of the manual so I couldn't tell you the fuse number, but check fuses first.
gsdreams is offline   Reply With Quote
Old 05-08-2008, 14:03   #4 (permalink)
Registered User
 
Join Date: May 2008
Posts: 4
Re: 03 windstar transmission problem

Quote:
Originally Posted by marklmarvin View Post
I have an 03 windstar that has really been a problem lately. Front springs, altenator, air conditioner, power steering pump, and brakes have all needed repair, with only 40,000 miles on vehicle. This morning I got in and started the van, and the transmission would not go into gear. It holds in park, but nothing happens when I shift into reverse or any forward gear. I drove in with no problems the night before! Anybody have any ideas?
Mark I had the same problem and had to get a new tranny at a cost of 3000 new, take it to a tranny place and let them take alook, this way you can have it rebuilt for alot less then I paid.

Good luck
Robert Tag is offline   Reply With Quote
Old 05-08-2008, 18:26   #5 (permalink)
Registered User
 
Join Date: May 2008
Posts: 6
Re: 03 windstar transmission problem

Hi there

Check your transmission range sensor or aka "neutral safety switch" this part is a common problem on all windstars. It is a black part that sits right on top of the transmission, remove the air filter assembly and look down it should be right there. Also, is the OD light on or blinking on and off, if it is there is a transmission code stored. Also when is the last time you changed your transmission fluid. The windstar only uses MERCON V.
nbjovo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:32.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.