06 4.2l freestar SEL won't turn over - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-10-12, 01:42 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 4
confused 06 4.2l freestar SEL won't turn over

Hello all. I have a 2006 Freestar SEL 4.2L. It died yesterday and won't turn over at all. Code reader says "No Link". When the key is in the on position the ?IMRC motor? runs constantly and so does another motor/pump mounted to the firewall between the cabin and engine compartment. This second motor has a hose running from it into the air intake plenum just behind the throttle body. I checked the fuses and relays related to PCM and starter and starter solenoid.

The second "motor/pump" is the vapor canister check valve.
Any ideas what it could be?

Thank you,
Brad

Last edited by blmatx; 03-10-12 at 02:26 PM. Reason: added vapor canister check valve to description
blmatx is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-10-12, 03:47 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 4
Re: 06 4.2l freestar SEL won't turn over

It was the 15AMP fuse under the hood that controls the PCM, injectors, and a few other things. I thought I had checked it but must have grabbed the wrong one the first time.
blmatx is offline  
post #3 of 5 (permalink) Old 03-11-12, 02:33 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,915
Re: 06 4.2l freestar SEL won't turn over

Glad you solved the problem , thanks for letting the forum know .
R.S.LOGAN is offline  
post #4 of 5 (permalink) Old 03-12-12, 03:46 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 4
Re: 06 4.2l freestar SEL won't turn over

Well the saga continues...

Not long after replacing the fuse the engine started missing and throwing P0352 code. I pulled the ignition coil pack and there was a large crack. Replaced the coil and put new plugs in since I had it opened up. I checked the PCM connector and sure enough there was water in there. I thought I dried it out pretty well, but now after putting it all back together I have a P050B. If I'm reading the Ford troubleshooting chart correctly, this is either wiring harness or PCM. I'm heading back out to tear it all down again and check for water/water damage.
blmatx is offline  
post #5 of 5 (permalink) Old 03-12-12, 05:53 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 4
Re: 06 4.2l freestar SEL won't turn over

Cranked up the air compressor and started blowing. A ton more water came out of the PCM connector. I pulled the PCM and opened it up and sure enough there is a blown resistor on the board. I'm taking a trip tomorrow to the junkyard. I am going to attempt to pick up a PCM and put a new-to-me resistor on the board.
blmatx is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome