1990 ford aerostar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-29-06, 03:55 AM Thread Starter
Registered User
 
Join Date: Mar 2006
Posts: 2
1990 ford aerostar

hello all

ok well i purchased a 1990 ford aerostar just recently for my mom, when we test drove it we had no problem, my problem is after driving for a while the vehicle just shuts off. i was told by my dad the family mechanic the its not getting gas, i have replaced the fuel sensor relay. and the same problem pursists. as of right now i am lost any suggestions will be greatly appriciated

smee342 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-29-06, 05:39 PM
Registered User
 
bertha66's Avatar
 
Join Date: Sep 2005
Location: Central Oregon
Age: 62
Posts: 198
Re: 1990 ford aerostar

If you are not getting any fuel you may need a fuel pump. When was the last time the fuel filter was changed? I out a new one in each spring. I also have 90 Areo 2wd with the 4.0 engine.
bertha66 is offline  
post #3 of 4 (permalink) Old 09-18-06, 01:17 PM
Registered User
 
Join Date: Aug 2006
Location: British Columbia, Canada
Age: 54
Posts: 26
Re: 1990 ford aerostar

hi
did you try to reset the fuel shut off switch (inertia switch)
tootalltechie is offline  
post #4 of 4 (permalink) Old 11-24-08, 10:45 AM
Registered User
 
Join Date: Nov 2008
Posts: 6
Re: 1990 ford aerostar

i would suggest replacing the coul for is know for cracked coils that cut out when they heat up especially if its the 3 ltr with the distributer.
Kevin Van Gend is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome