2000 Windstar 3.8 tranny issue! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-25-2013, 16:28   #1 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 18
2000 Windstar 3.8 tranny issue!

I was driving down the street and my Windstar acted like it was in neutral. Stepped on gas and it just revved. Pulled over and shut it off, restarted and it worked for a few blocks then did it again. Did this all the way home. What causes this?
seeya205 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-25-2013, 16:53   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 11,192
Re: 2000 Windstar 3.8 tranny issue!

Checked ATF level ?
R.S.LOGAN is offline   Reply With Quote
Old 05-25-2013, 17:41   #3 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

ATF is at proper level, smells good and is about 6 months old. I just had the sub frame, brake switch recall done about 10 days ago. Could they have messed something up? It was running fine before that!
seeya205 is offline   Reply With Quote
Old 05-26-2013, 06:25   #4 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2000 Windstar 3.8 tranny issue!

I didn't see any recalls on the brakes, but, the range selector may have been knocked or you could have a faulty solenoid on the transmission. Check for looseness or corrosion on electrical terminals going to the transmission.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 05-26-2013, 12:50   #5 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

It was the cruise control switch under the master cylinder. The connectors look good and it happens in a gears and with or without od on.
seeya205 is offline   Reply With Quote
Old 05-26-2013, 17:50   #6 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2000 Windstar 3.8 tranny issue!

So you found it, great!
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 05-26-2013, 18:52   #7 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

No that was what the recall was for!
seeya205 is offline   Reply With Quote
Old 05-27-2013, 08:34   #8 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2000 Windstar 3.8 tranny issue!

Crap. Well, like I said, check out the wiring to the transmission, often, you may not actually find the culprit, but it gets cured while doing several checks. If it's a faulty connection, they can be a pain to find, I generally start pulling all connections to a system, spraying with electronics cleaner and then lubricating the terminals with dielectric grease to keep them protected.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 07-17-2013, 23:36   #9 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 7
Re: 2000 Windstar 3.8 tranny issue!

Its in the valve body in the trany..you have a sticky valve/valves.. the trany in the windstar runs hot.. when you get a new trany have them put in the tow package upgrade..
blazz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:32.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.