2000 Windstar 3.8 tranny issue! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-25-13, 04:28 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 18
2000 Windstar 3.8 tranny issue!

I was driving down the street and my Windstar acted like it was in neutral. Stepped on gas and it just revved. Pulled over and shut it off, restarted and it worked for a few blocks then did it again. Did this all the way home. What causes this?

seeya205 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-25-13, 04:53 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,160
Re: 2000 Windstar 3.8 tranny issue!

Checked ATF level ?
R.S.LOGAN is offline  
post #3 of 9 (permalink) Old 05-25-13, 05:41 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

ATF is at proper level, smells good and is about 6 months old. I just had the sub frame, brake switch recall done about 10 days ago. Could they have messed something up? It was running fine before that!
seeya205 is offline  
post #4 of 9 (permalink) Old 05-26-13, 06:25 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 6,093
Re: 2000 Windstar 3.8 tranny issue!

I didn't see any recalls on the brakes, but, the range selector may have been knocked or you could have a faulty solenoid on the transmission. Check for looseness or corrosion on electrical terminals going to the transmission.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #5 of 9 (permalink) Old 05-26-13, 12:50 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

It was the cruise control switch under the master cylinder. The connectors look good and it happens in a gears and with or without od on.
seeya205 is offline  
post #6 of 9 (permalink) Old 05-26-13, 05:50 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 6,093
Re: 2000 Windstar 3.8 tranny issue!

So you found it, great!

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #7 of 9 (permalink) Old 05-26-13, 06:52 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 18
Re: 2000 Windstar 3.8 tranny issue!

No that was what the recall was for!
seeya205 is offline  
post #8 of 9 (permalink) Old 05-27-13, 08:34 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 6,093
Re: 2000 Windstar 3.8 tranny issue!

Crap. Well, like I said, check out the wiring to the transmission, often, you may not actually find the culprit, but it gets cured while doing several checks. If it's a faulty connection, they can be a pain to find, I generally start pulling all connections to a system, spraying with electronics cleaner and then lubricating the terminals with dielectric grease to keep them protected.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #9 of 9 (permalink) Old 07-17-13, 11:36 PM
Registered User
 
Join Date: Jul 2013
Posts: 7
Re: 2000 Windstar 3.8 tranny issue!

Its in the valve body in the trany..you have a sticky valve/valves.. the trany in the windstar runs hot.. when you get a new trany have them put in the tow package upgrade..
blazz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome