2000 windstar having rough idle!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-11-11, 01:56 PM Thread Starter
Registered User
 
Join Date: Jun 2011
Posts: 4
2000 windstar having rough idle!!

I have a 2000 windstar and i just got done replacing the port seals and intake gasket, IAC gasket, TB gasket and isolator bolts. the check engine light went off after i fixed it, but it is still idleing pretty rough. when in park at idle its pretty rough, if i press on the gas pedal it is still rough until it gets to about 2k rpms and it smooths out above that. the IAC valve is new, Mass air is new, cleaned egr ports inside intake, DPFE is new. i would figure that the rough idle would go away with the repairs, but it is still there. i am at a loss as to what to do next. I have done a lot of looking and researching but my situation seems to be different from what i have found.
I test drove it also, and when i came to a stop, the rpm's dropped to about 500 then came back up. It has decent throttle response just rough until it hits 2k.

Thanks in advance for any advice yall might have!!

***Ryan

Free5oh is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-11-11, 02:07 PM Thread Starter
Registered User
 
Join Date: Jun 2011
Posts: 4
Re: 2000 windstar having rough idle!!

also i am getting some pretty good spark knock. should i try and replace the EGR valve and EGR solenoid? or just the EGR valve? THanks again!!

***Ryan
Free5oh is offline  
post #3 of 5 (permalink) Old 06-11-11, 08:41 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2000 windstar having rough idle!!

Have you checked to see if there are any more codes? The light doesn't have to be on. It's possible the coil is arcing. Was it doing exactly same before all the work was done?

Bert
Bert is offline  
post #4 of 5 (permalink) Old 06-12-11, 03:34 PM Thread Starter
Registered User
 
Join Date: Jun 2011
Posts: 4
Re: 2000 windstar having rough idle!!

Idle is a little better, i cleaned the EGR but i am still getting a rough acceleration even when crusing at speed it will viberate the steering wheel and entire vehicle for that matter. when i let off the gas and just coast it will smooth out considerably. so i dont know know what to do next. im gonna try some fuel system cleaner and see what happens. unless some one has a better idea.....

thanks
Free5oh is offline  
post #5 of 5 (permalink) Old 06-13-11, 07:08 AM
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 2000 windstar having rough idle!!

Have you checked the Fuel injection rail?...did you take this off when replacing the Gaskets?

Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome