2001 Windstar Lean Bank 1/2 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-28-09, 09:31 PM Thread Starter
Registered User
 
Join Date: Jan 2008
Posts: 6
2001 Windstar Lean Bank 1/2

I have a 2001 Ford Windstar. The check engine light comes on for lean bank 1 and 2 at the same time. (I don't remeber the code numbers off hand but can get them.) Could this be an oxygen sensor problem when both 1st and 2nd bank codes come on at the same time. It runs and idles fine, still gets good fuel mileage. If anyone has any ideas before I start replacing oxygen sensors and looking for a vaccum leaks it would be appreciated.

Thanks,
Ryan

reel_story is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome