2003 Windstar A/C doesn't blow cold after Ford Changed Compressor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-03-08, 03:33 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 4
2003 Windstar A/C doesn't blow cold after Ford Changed Compressor

Good day,

Over the winter, the compressor clutch on my 03 winstar broke contaminating the system with metal...

Ford replaced the compressor and orifice tube then flushed the system real well.

Ever since then, the A/C does not keep up on hot days... If it gets above 90, it doesn't blow that cold... (temp readings near 60 with a meat thermometer in the vent, my 98 taurus still blows 39)

I've brought it into ford twice since then... they sit it in their garage and take a reading and call it good... The first time, I don't think they took it on a test drive... Last time, they did but It only got up to 82 that day. This week is supposed to be the hottest week of the year so I'm going to take it in again tomorrow, but anyone have any experience with anything like this?

The A/C used to ROCK... it was amazing last summer... after the work done over the winter, it barely keeps me from sweating...

Thanks!!!

bobtu is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-22-08, 08:11 AM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2003 Windstar A/C doesn't blow cold after Ford Changed Compressor

I'd tell Ford to fix it or give you a refund and keep the parts. They should have their parts warranted anyway. They can easily park it in the afternoon sun for an hour with the windows up and then test it out to see how it is functioning. Having it sit in their garage isn't a good way to get an accurate reading.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome