2003 Windstar SEL cd player problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-28-2009, 09:14   #1 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 2
2003 Windstar SEL cd player problems

Okay my 2003 Windstar has the 6 disc in dash CD player. When I started it up one day. Out of the blue the CD player displayed a CD error. I can not eject or use the CD player. If I restart the van or disconnect the battery (I had to replace the battery recently). It doesn't display the error. But then when I hit eject or try to access the CD's it instantly displays an error. Any info on how to fix this would be appreciated. Thanks in advance.

Shane
Mustangshane76 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-28-2009, 19:52   #2 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 2003 Windstar SEL cd player problems

Quote:
Originally Posted by Mustangshane76 View Post
Okay my 2003 Windstar has the 6 disc in dash CD player. When I started it up one day. Out of the blue the CD player displayed a CD error. I can not eject or use the CD player. If I restart the van or disconnect the battery (I had to replace the battery recently). It doesn't display the error. But then when I hit eject or try to access the CD's it instantly displays an error. Any info on how to fix this would be appreciated. Thanks in advance.

Shane
HHmmmmm

Hello and good day:

Is this an aftermarket CD Player you had installed...or OEM from Ford???

First I would check the fuse panel, and pull the fuse. Do you have an Owners Manual for your Windstar?? if not here is a like that may help...

https://www.fleet.ford.com/maintenan...ls/default.asp

Please advise further.
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 04-28-2009, 20:41   #3 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 2
Re: 2003 Windstar SEL cd player problems

This is an OEM unit. I dont have the owners manual here for me to look at. I thought this might be a common problem and someone could have a fix for. I will try to pull the fuse. But after disconnecting the battery and letting it sit for a good 20 min. or so. then re-connecting and having the exact same problem. The fuse might not work. But as I said I will give it a try. the next step is going to be to remove the unit and inspect it visually for anything that might be causing the problem. We have had some minor difficulties with the stock unit in the past. But since its my wifes van and not mine. The stock unit has sufficed and preformed better than most of the other multi-CD players I've had in times past. I do like it. I really want to know for sure what the problem is before tearing it apart. But I can't have it all I guess. Lets see what turns up.
Mustangshane76 is offline   Reply With Quote
Old 04-28-2009, 23:18   #4 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,146
Re: 2003 Windstar SEL cd player problems

Download Free owners manual here https://www.fleet.ford.com/maintenan...ls/default.asp
jwko is offline   Reply With Quote
Old 10-20-2009, 18:30   #5 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 1
Re: 2003 Windstar SEL cd player problems

Quote:
Originally Posted by Mustangshane76 View Post
Okay my 2003 Windstar has the 6 disc in dash CD player. When I started it up one day. Out of the blue the CD player displayed a CD error. I can not eject or use the CD player. If I restart the van or disconnect the battery (I had to replace the battery recently). It doesn't display the error. But then when I hit eject or try to access the CD's it instantly displays an error. Any info on how to fix this would be appreciated. Thanks in advance.

Shane
shane, I have the same problem. Your radio must be turned off before inserting or ejecting the cd. Push open the slot and you should see the disc.
Push on the disc with another disc and the cd should come out, if not use something a little stiffer such as a pair o tweezers. BE PATIENT it takes a few minutes sometimes.

Good Luck
rowdy roddy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:30.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.