2004 freestar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-01-09, 08:25 PM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 6
2004 freestar

today i go to leave work and backed up just fine, got to the spot where i wanted to start going forward and it went about 5 feet before loosing all power, it has never given any signs of slipping so i highly doubt the trans is shot. so i put it back in reverse and still nothing...weird. first reaction was that the torque converter was out but there was no fluid seeping out.



please help if you've encountered this proble

dave_k is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-03-09, 01:37 PM
Registered User
 
Join Date: Dec 2008
Posts: 10
Re: 2004 freestar

You need a new Torque converter. The transmission will have to be rebuilt, and the radiator flushed/replaced.

I hope you have a few thousand set aside in a rainy day fund =/
janeuner is offline  
post #3 of 3 (permalink) Old 08-06-09, 02:31 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2004 freestar

Quote:
Originally Posted by dave_k View Post
there was no fluid seeping out.
Stupid question: You did make sure the transmission fluid level was OK? Low fluid will cause slippage to the point where it won't hold a gear at all.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome