2004 freestar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-01-2009, 20:25   #1 (permalink)
Registered User
 
Join Date: Jul 2009
Posts: 6
2004 freestar

today i go to leave work and backed up just fine, got to the spot where i wanted to start going forward and it went about 5 feet before loosing all power, it has never given any signs of slipping so i highly doubt the trans is shot. so i put it back in reverse and still nothing...weird. first reaction was that the torque converter was out but there was no fluid seeping out.



please help if you've encountered this proble
dave_k is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-03-2009, 13:37   #2 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 10
Re: 2004 freestar

You need a new Torque converter. The transmission will have to be rebuilt, and the radiator flushed/replaced.

I hope you have a few thousand set aside in a rainy day fund =/
janeuner is offline   Reply With Quote
Old 08-06-2009, 14:31   #3 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,474
Re: 2004 freestar

Quote:
Originally Posted by dave_k View Post
there was no fluid seeping out.
Stupid question: You did make sure the transmission fluid level was OK? Low fluid will cause slippage to the point where it won't hold a gear at all.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.