2004 Freestar sputters after fuel filter change - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 11-04-13, 07:10 PM Thread Starter
Registered User
 
Join Date: Nov 2013
Location: Millville, New Brunswick
Posts: 5
2004 Freestar sputters after fuel filter change

Hello, thanks for reading and sorry if this is a dupe post.

2004 Free star 4.2L with approx 306000 kms. Torque converter was replaced. A few days ago it would cut out when idling so I replaced the fuel filter. It idles smooth now and will accelerate great from a stop. When I reach 70-80 kph it starts to stutter or jolt. RPMs will jump around slightly, up or down 100 and start to drop. At times it would drop to about 400 rpm and no respond to the gas pedal. I'd shift to neutral and coast to 60kph and back to drive and it would run fine again. As long as I stay around 60 kph it runs great. I've tried to read the codes but get an error.

I don't want to put too much in without direction. I'm going to put some fuel system cleanser to start there but before I put too much money in anyone ones have ideas for me?

Thanks again,
Andrew

anelson is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 11-04-13, 08:25 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2004 Freestar sputters after fuel filter change

I'd check for codes to get an idea as to what area the problem may be.

Bert
Bert is offline  
post #3 of 9 (permalink) Old 11-05-13, 11:23 AM Thread Starter
Registered User
 
Join Date: Nov 2013
Location: Millville, New Brunswick
Posts: 5
Re: 2004 Freestar sputters after fuel filter change

Unfortunately, when I try and read the codes I get an error stating it can't read the computer.
anelson is offline  
post #4 of 9 (permalink) Old 11-05-13, 11:40 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,804
Re: 2004 Freestar sputters after fuel filter change

When were the plugs last checked / replaced ? Possibly dropping a cyl . intermittently whilst under load due to plug / wire breaking down ?
R.S.LOGAN is offline  
post #5 of 9 (permalink) Old 11-05-13, 03:05 PM
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,960
Re: 2004 Freestar sputters after fuel filter change

Agree with ^^^^^^. Sounds as tho it is misfiring under load. Very common on this motor. The coil is a very common failure. Check plugs and wires as stated then post back


Sent from AutoGuide.com App
r-clar is offline  
post #6 of 9 (permalink) Old 11-06-13, 12:48 PM Thread Starter
Registered User
 
Join Date: Nov 2013
Location: Millville, New Brunswick
Posts: 5
Re: 2004 Freestar sputters after fuel filter change

I've been noticing that around here, but with the transmission issues that have come up with this model I want to make sure I place my money right. Thanks guys. Now to get the parts.
anelson is offline  
post #7 of 9 (permalink) Old 11-06-13, 12:51 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,804
Re: 2004 Freestar sputters after fuel filter change

Let us know how you get on with an update ? Could be money well spent , hopefully .
R.S.LOGAN is offline  
post #8 of 9 (permalink) Old 01-08-14, 09:56 AM Thread Starter
Registered User
 
Join Date: Nov 2013
Location: Millville, New Brunswick
Posts: 5
Re: 2004 Freestar sputters after fuel filter change

Well, the good news, it worked like a charm. Thanks to everyone for the help and support on the forums here. A great community. Plug one hole and another shows up. My ECM just broke today.

If anyone is having the issue with the ignition coil and you can't read your codes, make sure you check the ECM.

P.S. When you do this yourself, remember to hook your washer fluid line back up.
anelson is offline  
post #9 of 9 (permalink) Old 01-08-14, 10:55 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2004 Freestar sputters after fuel filter change

Thanks for the update. Glad you fixed it.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome