90 Ford E150 Club Wagon 1/2 ton 5.0 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-10-2011, 11:11   #1 (permalink)
Registered User
 
Join Date: Jan 2011
Posts: 1
confused 90 Ford E150 Club Wagon 1/2 ton 5.0

I have some problems maintaining the club wagon with the 302 engine. When I start and drive no problems until maybe ten minutes when all of a sudden it stumbles and cuts out on me. I try to restart it and it cranks but doesn't kick over. I wait maybe two three minutes and it starts back up. sometimes i can make it home without it stalling again, other times it will stall about four times before i get home. I have replaced the IAC valve and had no problems for about two weeks and then bam, it did it again. I went ahead and replaced the egr position sensor, tp sensor, fuel pump relay, eec relay, external fuel pump, fuel filter but it continues to die on me. today was the day i replaced the tp sensor and about 3/8 mile down the road it died. I restarted it and put it into gear and died. waited a minute and started it, put it into D and let off the brake and allowed it to coast me home (bout two blocks). Parked it and revved the engine and when it revved down it stumbled, backfired slightly, and died. I can go outside right now and start it without a problem. As soon as I drive it or if it idles there for a couple minutes it dies. the internal pump (fuel) is good. the spark plugs and wires and distributor, etc., are good. anyone with any suggestions? this has me stumped
unsuccessful is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.