92 Aerostar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-16-2004, 16:54   #1 (permalink)
Registered User
 
Join Date: Aug 2004
Posts: 2
92 Aerostar

Have a very unusual situation I am in need of help with
I had a fuse blow in the van that blew the dashboard gadets...once I replaced the fuse in the van evertything (speedomenter and odometer) now read in kph instead of mph.

The reason I am aware this is what it did was the day it happend was the day I registered it and still had a copy of the milage before the fuse blew (exactly differance was able to be divided by 1.67)...107000 miles became 178690 and the speedometer is also when traveling at 44 mph I am actually doing 55 mph (again 55/1.67 = 44 mph)

The Ford Dealers that I have spoken to said they have never heard of this happening and do not know how to fix it...I just moved to another state but have yet to check with a dealer here.

Any suggestions for this non-mechanical moron

Thanks
Don
DBIddle69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-2004, 16:29   #2 (permalink)
Registered User
 
Join Date: Aug 2004
Posts: 2
Re: 92 Aerostar

Since I posted this I have found that the problem is the instrument panel cluster but the local Ford dealer was not able to find a replacement nor did they offer a way to possibly reset the device.....anyone have a clue how I could reset this??

Thanks
DBIddle69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
92' year break info tim87114 Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 1 01-01-2006 16:01
'92 ford aerostar won't start, just clicks... then starts later tre2004 Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 6 09-12-2004 05:44
89 Ford Aerostar Rough Idle Jaime Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 16 09-11-2004 13:45
92 Aerostar Engine removal renchmunky Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 0 07-30-2003 12:10
92 aerostar runs rough oxnevad Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 0 04-30-2001 04:20

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.