96 windstar brake problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-26-04, 02:40 PM Thread Starter
Registered User
 
Join Date: Nov 2004
Age: 48
Posts: 2
96 windstar brake problem

I have a 96 ford winstar when I use the brakes the pedal goes all the way to the floor but they will pump up? I have change master cylinder and have bled the brakes numerous times, pads are good and nothing seems to be sticking,if anybody has a suggestion,would be greatly appreciated
ford f150 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 Ford Windstar Mydnight Myst Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 8 01-23-06 03:23 PM
VZ HSV pics & info FPRXR-6 The Pub 79 10-10-04 04:04 PM
'98 Windstar - Power seat problem BruceHoiberg Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 2 07-08-04 09:11 PM
Windstar 96 error code P0141 posadas Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 0 10-16-03 09:49 AM
EB11 Fairmont brake light problem Mel789 Suspension | Wheels&Tires | Brakes 2 04-20-02 09:02 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome