96 windstar wiper problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-08-11, 10:53 AM Thread Starter
Registered User
 
Join Date: May 2011
Location: Ohio
Posts: 2
96 windstar wiper problem

Have a 96 Windstar that the wipers do not turn on. They do work when you use the fluid spray. Checked fuses and relay switch with no luck. Any help would be great as the rain continues to fall in Ohio and most places around the country.

Thanks Simon

sisezz73 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-08-11, 06:11 PM
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 96 windstar wiper problem

Quote:
Originally Posted by sisezz73 View Post
Have a 96 Windstar that the wipers do not turn on. They do work when you use the fluid spray. Checked fuses and relay switch with no luck. Any help would be great as the rain continues to fall in Ohio and most places around the country.

Thanks Simon
Helllo and good day Simon:

This sounds like you have a boken switch..

1996 FORD WINDSTAR 3.0L 182cid V6 FI (U) OHV : Electrical-Switch & Relay : Wiper Switch WikiPriceSTANDARD MOTOR PRODUCTS Part # DS789 {Click Info Link for Alternate/OEM Part NumbersE88Z13K359AA, F58Z13K359A, F88Z13K359AA, F88Z13K359AB, SW5460}
Windshield Wiper Switch
$58.79Add to Cart

Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline  
post #3 of 4 (permalink) Old 05-08-11, 07:00 PM Thread Starter
Registered User
 
Join Date: May 2011
Location: Ohio
Posts: 2
Re: 96 windstar wiper problem

Thanks for the reply. Will check that out. Hopefully not to hard of a job since I have no clue what I am doing most of the time.
sisezz73 is offline  
post #4 of 4 (permalink) Old 05-11-11, 05:00 PM
Registered User
 
Join Date: May 2011
Posts: 5
Re: 96 windstar wiper problem

Simon did you check all the relays under the hood? There are three of them if I recall correctly.
pgeorge is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome