99 ford winstar electrical nightmare - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-18-10, 10:12 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 2
99 ford winstar electrical nightmare

Just Started yesterday I have a 99 windstar that about after 10 mins of running almost everything shuts down. The Blower cuts out, lose the radio, power windows and locks, all lights, the motor idles really rough and when you hit the gas pedal motor just dies out. When you try to restart the battery is almost dead and you just hear the starter clicking. If you let it sit for a couple hours everything will start working again for about the same amount of time (10min). I checked for shorts and grounding problems through out the electrical system found none. I think my front ECM is shutting down Had to replace the rear one about two years ago for losing all rear lights and other issues. Was wondering if anyone has had similar problems and comment on my thoughts. Really cant afford a new got to keep this one going
Thanks

foyjac is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-18-10, 11:25 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 99 ford winstar electrical nightmare

Maybe it's not charging. Check the volts at the battery when it's running and see if you're getting about 14 volts. I think Autozone will check for free.

Bert
Bert is offline  
post #3 of 4 (permalink) Old 07-18-10, 12:45 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 2
Re: 99 ford winstar electrical nightmare

After adding this post I sat and thought about what might be going wrong and that was exactly it. tested the alternator while the engine was running and no voltage was present, the longer the engine ran with acc. on the lower the voltage got until not enough for the ECM to operate. For some reason I always think of the most difficult than the most reasonable ( start with the basics) will be driving again soon
foyjac is offline  
post #4 of 4 (permalink) Old 07-18-10, 12:47 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 99 ford windstar electrical nightmare

Thanks for the update. We all do that sometimes.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome