99 Windstar 3.8 fuses 1,3,5 dead at power box under hood - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-16-2013, 09:48   #1 (permalink)
Registered User
 
Join Date: May 2013
Posts: 2
99 Windstar 3.8 fuses 1,3,5 dead at power box under hood

Van cranks fine, and runs fine when I pour a little gas into throttle, until gas is gone, of course. No sound from fuel pump. Battery has 12.4v but only get 6.8v at fuel cutoff in rear. Relay in power box under hood checks out OK. I have discovered that I cannot detect any current at all in fuses 1, 3, and 5 in the power dist box under the hood. Took bottom off box and used mirror to view the fuse sockets from underside, and wires appear normal--no burns and appear to be tightly attached to terminals which contact fuse blades.

Is there a component elsewhere that might have gone bad that controls power to these 3 fuses? Fuse 1 feeds the PCM, and fuse 5 feeds the fuel pump motor, so I am pretty sure this is the problem. Can't remember what fuse 3 does and don't have manual in front of me to check, but I think it too was related to fuel delivery.

Been seeing references to a CCRM in other threads. Could that be involved? THANK YOU for any help. I need to get this running soon since my daughter needs it.

Last edited by mrohio55; 05-16-2013 at 09:51. Reason: grammar
mrohio55 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-16-2013, 15:03   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 99 Windstar 3.8 fuses 1,3,5 dead at power box under hood

There are several fuses that are powered with the same link. Check fig. 1 | Repair Guides | Power Distribution (1999) | Power Distribution (1999) | AutoZone.com
__________________
Bert
Bert is offline   Reply With Quote
Old 05-23-2013, 10:20   #3 (permalink)
Registered User
 
Join Date: May 2013
Posts: 2
Re: 99 Windstar 3.8 fuses 1,3,5 dead at power box under hood

Thanks for the schematics, Bert. Looking at them, I can't see anything between the battery and the power box, like a CCRM. Plus, other sources say the CCRM wasn't used in the Windstar after 97. Not to mention that I have looked high and low for it on my 99. It isn't there.

Is there a way to apply battery power directly to the fuel pump, bypassing the PCM, relays, power box, etc? I would like to eliminate, or confirm, the fuel pump as the problem before I start the hassle of looking for bad grounds (I did clean a couple already--no luck), and chaffed wires.

If I can apply power directly to the pump, the results of the test will eliminate a lot of uncertainty as I try to find out why this thing won't start. Thanks very much.
mrohio55 is offline   Reply With Quote
Old 05-23-2013, 14:41   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 99 Windstar 3.8 fuses 1,3,5 dead at power box under hood

There has to be power in the fuse box for the horn, PCM and other items. You should be able to power it from the relay position when the relay is removed.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:49.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.