99 Windstar Fuel Pump/relay issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-15-2009, 09:26   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 4
confused 99 Windstar Fuel Pump/relay issue

Good day;
Hope someone out there can possibly steer me in the right direction. Problem started on a 25 mile trip. Shut engine off to pickup some merchandise. Came out to start and would crank and try to start but wouldn't stay running. Had to be towed. Mechanic found Fuel Pump reset switch tripped and Fuel Pump fuse underhood blown. Reset switch and replaced fuse. Car driven locally for 2 weeks with NO problems. Car taken on another trip, stopped at station for gas and when leaving "check engine" light came on. Car driven for another 20 miles and stopped for 45 minutes. came out and would turn over but again would not run. Car sat for approx 45 minutes, reset switch was checked and not tripped, fuse was removed and checked but not blown. New fuse was installed anyhow and for whatever reason engine started with check engine light on. Upon getting home light code was checked and told of "LOW VOLTAGE, FUEL SYSTEM". I am not sure what code number is. I have a new fuel filter ready to replace, old one is a year old. Been doing some reading on the Fuel Pump relay but not sure how to go on. Dont want to go spending 600 for a pump replacment if not needed. Any help is appreciated......tks
nascar19036 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-17-2009, 18:36   #2 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 99 Windstar Fuel Pump/relay issue

Quote:
Originally Posted by nascar19036 View Post
Good day;
Hope someone out there can possibly steer me in the right direction. Problem started on a 25 mile trip. Shut engine off to pickup some merchandise. Came out to start and would crank and try to start but wouldn't stay running. Had to be towed. Mechanic found Fuel Pump reset switch tripped and Fuel Pump fuse underhood blown. Reset switch and replaced fuse. Car driven locally for 2 weeks with NO problems. Car taken on another trip, stopped at station for gas and when leaving "check engine" light came on. Car driven for another 20 miles and stopped for 45 minutes. came out and would turn over but again would not run. Car sat for approx 45 minutes, reset switch was checked and not tripped, fuse was removed and checked but not blown. New fuse was installed anyhow and for whatever reason engine started with check engine light on. Upon getting home light code was checked and told of "LOW VOLTAGE, FUEL SYSTEM". I am not sure what code number is. I have a new fuel filter ready to replace, old one is a year old. Been doing some reading on the Fuel Pump relay but not sure how to go on. Dont want to go spending 600 for a pump replacment if not needed. Any help is appreciated......tks


Hello and good day to you:

I am sorry to say this is a classic Fuel Pump problem....Replace the Fuel Filter any way this may relieve some of the pressure in the Vent Canister.

Good luck and good repairing.
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 04-20-2009, 03:01   #3 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 4
Re: 99 Windstar Fuel Pump/relay issue

Thanks Sterling 6. I've replaced the fuel filter and after a couple of days no idiot light on dash and continues to run ok. Probably running on borrowed time with the pump.
nascar19036 is offline   Reply With Quote
Old 01-27-2012, 15:05   #4 (permalink)
Registered User
 
Join Date: Jan 2012
Posts: 1
Re: 99 Windstar Fuel Pump/relay issue

Check fuel reset switch as noted above (by spare tire) also check fuel pump fuse, then swap the horn relay with the fuel pump relay. (they are both the same type relay) Use owners manual to locate relays under the hood by the battery.
Robertez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:42.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.