99 windstar speedometer - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-17-2009, 15:06   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 17
99 windstar speedometer

the speedometer don;t work anymoore and also the digital odometer only show -------- small bars across the disply insted of number. What is the best way to fix this.
Thank's
windstar98 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2009, 06:48   #2 (permalink)
Registered User
 
Join Date: Jun 2009
Posts: 9
Re: 99 windstar speedometer

I'm waiting to hear from someone also. Mine was intermittent and then it stopped altogether. I bought a speed sensor but a transmission shop did diagnostic and they said it wasn't the speed sensor. I guess we're looking toward the vehicle speed sensor and/or the cable. My odometer is showing the actual mileage that the thing quit at. 136540.6. Good luck.

Rob

Quote:
Originally Posted by windstar98 View Post
the speedometer don;t work anymoore and also the digital odometer only show -------- small bars across the disply insted of number. What is the best way to fix this.
Thank's
RobbyEMT is offline   Reply With Quote
Old 06-18-2009, 16:35   #3 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 17
Re: 99 windstar speedometer

I found the problem , the fuse #10 under the dash was blown. Replaced it and it fix the speedometer,odometer,abs light that was on all the time. Still trying to fix low brake pedal.on first hit the pedal is high, release and hit again and it goes down,if i do that 4 or 5 time the pedal will hit the floor and no more brakes. Master cylinder was changed a while back, i think it's the bleeding, will see.
windstar98 is offline   Reply With Quote
Old 06-21-2009, 14:57   #4 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 17
Re: 99 windstar speedometer

I also found the problem with the brakes. The new rebuilt master cylinder was faulty,had to replace it ,and now it's working good.
Thanks
windstar98 is offline   Reply With Quote
Old 07-04-2009, 08:56   #5 (permalink)
Registered User
 
Join Date: Jun 2009
Posts: 9
Re: 99 windstar speedometer

Glad to hear everything worked out for you. MY transmission went while wife was 200 miles from home. I got tow dolley and got it home. Looks like a line was leaking and it ran dry. Hope that is all. Speedometer is last on my list right now.

Rob
RobbyEMT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.