99 windstar speedometer - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-17-09, 03:06 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 17
99 windstar speedometer

the speedometer don;t work anymoore and also the digital odometer only show -------- small bars across the disply insted of number. What is the best way to fix this.
Thank's

windstar98 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-18-09, 06:48 AM
Registered User
 
Join Date: Jun 2009
Posts: 9
Re: 99 windstar speedometer

I'm waiting to hear from someone also. Mine was intermittent and then it stopped altogether. I bought a speed sensor but a transmission shop did diagnostic and they said it wasn't the speed sensor. I guess we're looking toward the vehicle speed sensor and/or the cable. My odometer is showing the actual mileage that the thing quit at. 136540.6. Good luck.

Rob

Quote:
Originally Posted by windstar98 View Post
the speedometer don;t work anymoore and also the digital odometer only show -------- small bars across the disply insted of number. What is the best way to fix this.
Thank's
RobbyEMT is offline  
post #3 of 5 (permalink) Old 06-18-09, 04:35 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 17
Re: 99 windstar speedometer

I found the problem , the fuse #10 under the dash was blown. Replaced it and it fix the speedometer,odometer,abs light that was on all the time. Still trying to fix low brake pedal.on first hit the pedal is high, release and hit again and it goes down,if i do that 4 or 5 time the pedal will hit the floor and no more brakes. Master cylinder was changed a while back, i think it's the bleeding, will see.
windstar98 is offline  
post #4 of 5 (permalink) Old 06-21-09, 02:57 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 17
Re: 99 windstar speedometer

I also found the problem with the brakes. The new rebuilt master cylinder was faulty,had to replace it ,and now it's working good.
Thanks
windstar98 is offline  
post #5 of 5 (permalink) Old 07-04-09, 08:56 AM
Registered User
 
Join Date: Jun 2009
Posts: 9
Re: 99 windstar speedometer

Glad to hear everything worked out for you. MY transmission went while wife was 200 miles from home. I got tow dolley and got it home. Looks like a line was leaking and it ran dry. Hope that is all. Speedometer is last on my list right now.

Rob
RobbyEMT is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome