99 Windstar won't idle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-23-05, 03:43 AM Thread Starter
Registered User
 
Join Date: Sep 2005
Age: 44
Posts: 1
99 Windstar won't idle

I have a 99 Windstar with the 3.8 V6. It was leaking oil from the valve cover gaskets and the engine lite was always on. It also would die when it was idling, put in reverse, or you let your foot off the gas pedal. We drove it with 2 feet to keep it running. I read somewhere that the valve covers were the problem cause they let air in and made the engine run lean.

So I've changed the valve cover gaskets and air filter. It ran good for about a day then it went back to dying.

Also, it makes a rattling sound when you accelerate. It doesn't do it right after I service the engine, but in a day or two it starts again.

Any help would be appreciated.

Kell is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-15-05, 06:33 AM
Registered User
 
Join Date: Dec 2005
Posts: 3
Re: 99 Windstar won't idle

I have the same idling problem now & I am taking it to the dealership. How was yours fixed?

About the noise, we had the same problem a couple of years ago & a tune-up fixed it - plugs & wires. The guy at the service department said the baffles had cracked & wanted several hundered dollars to "fix it".
tpapay is offline  
post #3 of 4 (permalink) Old 12-15-05, 07:25 AM
Registered User
 
Join Date: Dec 2005
Posts: 3
Re: 99 Windstar won't idle

Quote:
Originally Posted by tpapay
I have the same idling problem now & I am taking it to the dealership. How was yours fixed?

About the noise, we had the same problem a couple of years ago & a tune-up fixed it - plugs & wires. The guy at the service department said the baffles had cracked & wanted several hundered dollars to "fix it".
I checked & the DPFE sensor was also replaced with the wires & plugs.
tpapay is offline  
post #4 of 4 (permalink) Old 12-15-05, 10:47 AM
Registered User
 
Join Date: Dec 2005
Posts: 3
Re: 99 Windstar won't idle

As noted, my windstar would not idle either, & I two-foot drove it to the closest dealer.

The recommendation is to replace the idle control valve/motor. $105 cost from the parts department + labor.

They also recommended carbon cleaning & fuel injector cleaning, but I'm a sceptic & will not pay the high cost for this "cleaning"
tpapay is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome