Chronic Inner Tie Rod Problem - Suggestions? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-16-2008, 04:08   #1 (permalink)
Registered User
 
rog64ert's Avatar
 
Join Date: Oct 2008
Posts: 2
Chronic Inner Tie Rod Problem - Suggestions?

I have a 2000 Windstar. It is becoming a rougher ride these days. For the past 3 years at inspection time I have had to replace the right inner tie rod. 4 years ago it was the left and this year I have to replace the left one again as well. I have noticed that the sway bar links are shot as well, and recently had the struts replaced. Of course it also will not stay aligned. Any suggestions as to cause and /or solution? Thanks

Last edited by rog64ert; 10-31-2008 at 04:30. Reason: missing info
rog64ert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2008, 17:43   #2 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: Chronic Inner Tie Rod Problem - Suggestions?

Quote:
Originally Posted by rog64ert View Post
It is becomming a rougher ride these days. For the past 3 years at inspection time I have had to replace the right inner tie rod. 4 years ago it was the left and this year I have to replace the left one again as well. I have noticed that the sway bar links are shot as well, and recently had the struts replaced. Of course it also will not stay aligned. Any suggestions as to cause and /or solution? Thanks


What Vehicle is this??? Need some basic info...lol
Sterling_Six is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.