E150 5.0 problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-21-2009, 15:44   #1 (permalink)
Registered User
 
Join Date: Aug 2009
Posts: 2
E150 5.0 problem

Ok my friend owns a 1991 E150 5.0L. Basically what it is doing is, when you try to start it, it cranks but wont turn over unless you pump the gas pedal. Then once you get it to start you have to continue to pump the pedal to keep it running.
Ill just list everything I did and checked:
Fuel pressure test: 40psi
Pulled the injectors and had them tested
Changed IAC
Changed EGR
Checked plugs, wires, distributor cap/rotor, ignition coil
Cleaned a bit of carbon build up off the throttle body.

Theres no CEL on and I have no idea what else to look at...
brndnbess is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2009, 18:55   #2 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: E150 5.0 problem

Quote:
Originally Posted by brndnbess View Post
Ok my friend owns a 1991 E150 5.0L. Basically what it is doing is, when you try to start it, it cranks but wont turn over unless you pump the gas pedal. Then once you get it to start you have to continue to pump the pedal to keep it running.
Ill just list everything I did and checked:
Fuel pressure test: 40psi
Pulled the injectors and had them tested
Changed IAC
Changed EGR
Checked plugs, wires, distributor cap/rotor, ignition coil
Cleaned a bit of carbon build up off the throttle body.

Theres no CEL on and I have no idea what else to look at...





Hello and good day:


How about your Fuel Filter?? You did not mention this.

Also did you happen to think of replacing the TPS (throttle positioning Sensor)??
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 08-21-2009, 20:08   #3 (permalink)
Registered User
 
Join Date: Aug 2009
Posts: 2
Re: E150 5.0 problem

Sorry forgot to mention everything. I did change the fuel filter and TPS both and the fuel regulator. But I think i figured out the problem. If i stand there and spray carb cleaner into the throttle body it will stay at a perfect idle until i stop spraying. So its running to lean which i believe is a fuel injector(s) not working properly. Even though I already pulled the injectors out and had them tested, I think I'm going to go ahead and pull them back out again and take them up to a ford dealership and have them test them. Guess I'll see what happens.
brndnbess is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.