Failed digital cluster. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-13-11, 01:14 PM Thread Starter
Registered User
 
Join Date: Mar 2011
Posts: 2
Failed digital cluster.

'92 Eddie Bauer.
Fuse blew, replaced fuse but still no cluster "illumination". Cluster internal DC-DC voltage up-converter n-channel FET was solid short and trace was open. Replaced FET, repaired trace, now have ~46 volts and filament drive but still no "live" cluster.

Any ideas, experience...?

Anyone know of an available replacement cluster..??

wwest is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome