Intermittant Acceleration problem 94 Club Wagon - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-28-08, 08:33 PM Thread Starter
Registered User
 
Join Date: Aug 2008
Posts: 1
Intermittant Acceleration problem 94 Club Wagon

I have a 94 Clubwagon and have recently replaced the fuel pump and fuel filter. Ran great, for a while, and then started having issues where it randomly wouldn't accelerate correctly. To manipulate it to drive you would need to push the gas pedal and let off, when you let off it would get the gas, when you pushed on it, it would cut out. Idle runs rougher as well.

Originally thought fuel gauge was bad, and had low fuel, as it would run better after putting in gas, worse as that gas ran out.

Has nearly a half tank now, drove it for over a week, never letting it get lower than 3/8 tank, 30+ miles or more at a time, nothing wrong.

Drove it 6 blocks, started up again.

Codes are reading EGR valve fault, and now throttle position sensor above maximum voltage.

Any ideas if it could be the sensor, or maybe a vacuum leak? Bad fuel pump?
teecey is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome