Location of MAP sensor '93 Aerostar? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-12-05, 08:02 PM Thread Starter
Registered User
 
Join Date: Aug 2005
Posts: 1
confused Location of MAP sensor '93 Aerostar?

I have a 1993 Eddie Bauer edition Aerostar with the 4.0L engine

I cannot for the life of me, find the MAP sensor. (not on the top middle of the firewall)

I started experiencing rough idle and light spark knock on acceleration about two weeks ago. I replaced the MAF sensor but it didn't make any difference.

There has also been some tranny fluid disappearing, so I suspect the Modulator is faulty and has messed up the MAP sensor.

I've spent two evenings searching the internet for vacuum diagrams, or MAP sensor locations, but have only come up with similar diagnostics, but the only hint as to the location of the MAP sensor, was the top middle of the firewall.

Anyone have a better hint?

VicJr
VicJr is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome