No sound from Premium System - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-13-03, 01:04 AM
dhoang
Guest
 
Posts: n/a
confused No sound from Premium System

I can't get any sound from the speakers in my 95 Windstar. After checking the wiring harnesses and testing the controls nothing seems to work.

One clue is the headset jacks still work for the controls in the rear seats. From what I read the problems is with the amplifier that powers the speakers.

Where is this friggin amp? I already ripped out a few panels and busted some snap-on connectors today troubleshooting so any help would be appreciated.

Dan

 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-16-03, 01:34 PM
Registered User
 
Join Date: Apr 2003
Posts: 7
no sound

My Dad has this kind of system but I don't know if he has an amp. Usually they say it is located under the seat. He gets a really loud pop sometimes when he turns his off - did you ever get that? I was gonna say maybe the speakers are bad or the speaker wire is bad but if they're all out...I don't know. Here are some websites I occasionally use for car audio info. They should be more useful than this site. There are alot of experts that may be able to help you.

www.CarAudioForum.com

www.carsound.com

http://forum.sounddomain.com

http://www.the12volt.com/installbay
doombious is offline  
post #3 of 3 (permalink) Old 05-29-03, 11:23 PM
dhoang
Guest
 
Posts: n/a
I found the amp, it is hidden behind the globe box. Rather than spending more time to figure out if the problem is the amp or stereo, I still think it's the amp because the headphones work when the stereo is on, I've order JBL amp bypass wires for my new CD.
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BA Falcon Interior Reveal RPO83 Ford Worldwide News 5 09-16-03 07:12 PM
Improved Lincoln Navigation System Now Available On All Models RPO83 Lincoln 0 04-16-03 05:40 AM
Ford Product-Led Transformation: 2003 RPO83 Trans | Driveline 0 07-22-02 07:48 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome