windstar rough idle loss of power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-07-06, 07:36 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 2
frown windstar rough idle loss of power

Hi,
I have a 95 ford windstar 150,000 on it. on the way home tonight I noticed it was idling rough- about halfway and 3/4 between the 1000 rpm mark and with no warning it started to buck intermitenly and lost power - would drop from 45mph to 35mph going uphill.
I was able to get it home (25 mile drive) - any idea what may cause this? Also - no warning lights where on. - Thanks!

grumpy01 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-07-06, 07:37 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 2
Re: windstar rough idle loss of power

oops - it the 3.8 - Thanks again!!!
grumpy01 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome