'01 SCrew 4x4 turn signal stops when brakes applied - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-07-08, 08:09 PM Thread Starter
Registered User
 
Join Date: Nov 2007
Posts: 5
'01 SCrew 4x4 turn signal stops when brakes applied

Hi all,
I've had fun getting info from searching past threads and reading the discussions. Now I can't find a fix. My '01 SCrew's turn signal lights both flash when I turn the right or left turn lever on. To make it more confusing, in the cab the turn indicator flashes unless I hit the brakes, then they stop (inside the cab, outside the flashers are still both going) Any ideas? Thanks
Jmc

FYI I did check the lamps and the fuses. They're all fine.

Update...Problem solved. The flat 4 trailer connection had a bad ground. (I haul a trailer almost every day) Fixed the ground and am back on track.


Last edited by jmc0309; 06-07-08 at 10:50 PM. Reason: addendum
jmc0309 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome