1996 F150 302 4X4 EFI with two problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-19-2005, 03:43   #1 (permalink)
Registered User
 
Join Date: Jan 2005
Posts: 8
1996 F150 302 4X4 EFI with two problems

I have two problems that I cannot get an answer for or figure out. The truck has 271,000 miles and is running strong.
The first is electrical. My battery light is going on and off. The battery is is fine and is charging when running. It does not seem to be affecting anything but it is bothering me that something may be wrong.
The next is a strange noise that I hear when I am giving the truck gas at all speeds. It sounds like I have a turbo charger. I know I need a throw-out bearing because it whines when I depress the clutch (5 speed manual). Could this be also whining when the gas pedal is depressed?
I would appreciate any ideas.
dpbrowne is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EFI 302 Windsor Fuel Economy... Extreme_2020 Windsor Tech 25 12-13-2004 18:47
noisey 302 efi 96 ef2 xr8 twofellas Windsor Tech 3 11-08-2004 01:49
setting base ign timing on efi 302 eb? ebv888 Windsor Tech 8 10-27-2004 01:58
Need Help On EFI 302 sbf_302 Windsor Tech 4 10-26-2004 01:05
oil filter on efi 302 Fairlane Boy General Tech 5 02-10-2002 02:50

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:19.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.