351 needs some help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-07-2005, 15:59   #1 (permalink)
Registered User
 
Join Date: Apr 2005
Posts: 2
351 needs some help

I recently purcased a 1989 F-150 that sat for two year, now I expected some problems but it's getting out of control, I have replaced the high preassure fuel pump, fuel filter, plugs, wires, dist cap, and Rotor Button, map sensor, and bought a code checker, and I still can't figure out whats going on. My truck will start than even if im ideling at high rpm is backfires into the airfilter and dies. than when I try to restart i skips sputters and backfires more but won't restart. I have sunk alot of money and parts into this and im getting frustrated any help would be great. I think oxygensensor but im not sure.
broketruck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-09-2005, 06:36   #2 (permalink)
Registered User
 
Join Date: Mar 2005
Posts: 40
Re: 351 needs some help

fuel injected 351 89 f150 WOW, i wish australia made them.we only have 5lt,my method on 351(petrol carbie) is that if it backfires out the exhaust it's fuel,air,etc and if it backfires out carbie (airfilter) its timing,spark,firing order,etc.i dont think its u oxygen sensor as i have disconected them before as it will still drive fine except for idel use to go up&down and bad fuel economy but thats was a toyota celica.not a V8 ford.I may be wrong,about this whole thing but trying to help.so to me i think ur 1 firing order is wrong or ur timing is out or ur tps switch is out.
scrapper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.