5L cylinder 8 miss - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-26-10, 08:48 AM Thread Starter
Registered User
 
Join Date: Jun 2008
Posts: 9
5L cylinder 8 miss

my 1990 f150 started pinging under load. I changed plugs and wires aswell checked the timing. Now cylinder 8 has quit firing under load, there is spark but not firing as plug is wet and timing light on that wire indicates no fire. I had this problem on a 2.9 ranger on cylinder 2 and after changing the ignition set out I changed the distributor out of despiration and that was it. Has anyone else had this problem or any advise. I think it must be a pickup problem?
gloria77 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-26-10, 09:17 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: 5L cylinder 8 miss

Have you checked the compression? Maybe a valv is stuck or some other problem.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome