7.3 Leaking Oil Under Fuel Filter - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-19-08, 03:47 AM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 3
7.3 Leaking Oil Under Fuel Filter

Hey All.

My '99 350 7.3 lt is leaking oil on the drivers side of the fuel filter. Under the fuel filter housing are tww braided lines that are high pressure oil lines. ( I think they might have to do with the injector pump?? don't know) But I can watch the oil leak out as the engine is running. It used be be a drip but is getting worse. I understand that it's probably an O-ring issue???

Does anyone know about this?? Help, Please.....And how difficult to repair myself??

Thanks

GH

gharr8 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-28-08, 09:14 PM
Registered User
 
Join Date: Nov 2008
Posts: 2
Re: 7.3 Leaking Oil Under Fuel Filter

Most likely an O-Ring issue. Mine began to leak, I thought it was the high pressure oil pump, but it wasn't. The kit itself is really cheap at your local parts house, and it was relatively easy to change. If you are not mechanically inclined, I would let someone do it for you.
blakemedic51 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome