'79 brake problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-12-2009, 18:01   #1 (permalink)
Registered User
 
jo14's Avatar
 
Join Date: Mar 2007
Location: Ashland, Wi
Posts: 46
'79 brake problems

I have a '79 F-150 and the brakes worked awesome, it could stop on a dime. It was sitting for a week, and when I went to start it to move it and had no brakes what so ever. Checked the master cylinder and it was dry. So I pressure washed the under body and topped of the brake fluid to look for a leak, but can't find one. The only thing I can think of is the master cylinder is shot, but the doesn't explain why I can't find the leak. I don't want to replace the whole brake system and find out it was something simply. Any ideas??
jo14 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-12-2009, 18:26   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: '79 brake problems

If it has power brakes, the fluid probably leaked into the booster. You'd need a new master cylinder then.
Bert is offline   Reply With Quote
Old 11-12-2009, 18:32   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: '79 brake problems

After you pressure washed it, did you let it dry before checking for a leak? And was it the rear reservoir that was low?
Bert is offline   Reply With Quote
Old 11-12-2009, 20:25   #4 (permalink)
Registered User
 
jo14's Avatar
 
Join Date: Mar 2007
Location: Ashland, Wi
Posts: 46
Re: '79 brake problems

I was thinking that is was leaking into the booster, I just wasn't sure. And yes I let it dry over night. Thanks for the help
jo14 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.