'82 F-150 Accelerator Failure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-11-2008, 01:53   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2
'82 F-150 Accelerator Failure

Hi all,

First Post, Glad I found the place.

I got a pretty good deal from a friend and bought this 82 F-150 with a 302 and Holley 4 barrel. I hope to restore it bit by bit. It Runs great, starts without a hitch.

I do have a problem though, on my way home from work tonight the accelerator stopped working. Luckily it's not far from home.

I looked in my Haynes Repair Manual for some hints but couldn't find anything.

So, it still starts fine, and I can throttle fine (Via the carburetor) but pressing the accelerator does nothing I can see/feel.

One friend suggested a broken cable or linkage between the pedal and the The accelerator depresses and returns normally, it does not seem to be stuck.

Another suggested that it may be a clogged fuel filter or bad fuel pump.

Any suggestions would be of great help

Thanks
Qlippoth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-11-2008, 04:06   #2 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,706
Re: '82 F-150 Accelerator Failure

If you can throttle fine at the carb, but not with the accelerator, it is most likely the cable or disconnected at the pedal or the carb. Should be easy enough to figure out.
thefonz is offline   Reply With Quote
Old 07-20-2008, 20:13   #3 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2
Re: '82 F-150 Accelerator Failure

yep, it was the throttle cable, it had become disconnected from the engine bracket. Could not see it in the dark. Thanks for your help!
Qlippoth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.