86 F150 just went dead - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-23-07, 06:46 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 1
86 F150 just went dead

Truck running fine, son parked it and next time went to get in it it was dead.
battery less than 3 weeks old. Replaced the positive cable and the solenoid.
No juice no where. No headlights, dash lights - nothing. Checked ground cable
connection with a test probe off the + side of the battery, it says I have ground. I'm not getting any juice off the solenoid that leads to the starter.
Oh yes, swapped battery out with a known good one. Anyone have any ideas?

Tatonka is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-24-07, 05:29 PM
Registered User
 
Join Date: Apr 2007
Posts: 9
Re: 86 F150 just went dead

Ignition switch is one possibility.
CyberCrone is offline  
post #3 of 3 (permalink) Old 10-24-07, 05:44 PM
Registered User
 
Join Date: Apr 2007
Posts: 9
Re: 86 F150 just went dead

Hey, I don't know what happened to my post. All but one sentence disappeared. Anyway, here's the rest.

I have the same year F-150. When the electronic ignition module goes, it goes 100%. Fine one minute, nothing the next. I now carry a spare because when that thing goes out, there's nothing you can do except get towed. About $50 to carry the spare but worth it compared to towing charges.

Next possiblity is ignition switch. Best to eliminate every other possibility first because it's a pain in the assets to get to. You have to lower steering wheel to get to it, which requires tht you remove instrument panel cover, and the light switch and windshield wiper switch are a ditch to get off.

CyberCrone
76 and still truckin'
CyberCrone is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome