86 F150 won't start when cold, low gas mileage - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-24-07, 05:58 PM Thread Starter
Registered User
 
Join Date: Apr 2007
Posts: 9
86 F150 won't start when cold, low gas mileage

...but once it starts it runs fine, good power, engine runs smooth, plenty of crank power, so I tend to think it is not electrical. Could I be wrong about that? Gas mileage sinking, too. Can't remember when I last put a fuel pump in this precious old clunker but it was certainly a long time ago. I am wondering if a fuel pump performs poorly in cold weather when it is wearing out?

How tough is it to put a fuel pump in this year and model?

I am thinking fuel filter too but it's only been a few months since I put a new one in and not many miles since then.

CyberCrone
76 and still truckin'

CyberCrone is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome