94 F150 4X4 Trans shift problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-27-07, 06:21 PM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 2
94 F150 4X4 Trans shift problems

My truck has 365,000 km on it and has always been serviced by myself. As of late the trans shifts really hard up and down the gears when it is hot, but only when it is hot and not all the time. It is definitely not a mechanical problem. Also when you put it into 4X4 electric shift the 4X4 light comes on and it engages fine, but if you then put it into 4 low the light won't come on but it does engage and we can drive it in first gear but the trans will not shift gears until you rev it up to about 3,000 rpm and back off on the gas. Then it shifts real hard. This happens cold or hot every time it's engaged. I have replaced the sensor in the rear end, tried different ECM's, replaced the 4X4 shift relays. PS. the speedometer quits from time to time but a good whack on the dash usually makes it go again. Everything else works well and it is still a good looking truck. Any ideas would be greatly appreciated. Thanks from Grandora, SK.

grandora is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome