'94 Running Rough - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-07-2004, 08:05   #1 (permalink)
Atlantis167
 
Join Date: Oct 2004
Location: Ohio
Age: 30
Posts: 4
frown '94 Running Rough

I've never used these things before but I'm running out of options. I'm a college student in Ohio and I depend on my 1994 F-150 to get me home and back every couple weeks. Last spring the truck started acting up on me. As I was driving I went to get on the gas and nothing happened. The check engine light would come on immediately afterwards. I had it put on the computer at a Ford dealership and they said it was the O2 sensor, so I had that replaced. It continued. As of now, I've also had the rear converter taken out because it had gone bad, and replaced the EGR valve because a code had shown up that it was bad. It still runs rough on the road with no throttle response, and has started a bad habbit of staling out at idle, whether I'm parked or at a stop light. I don't have the time or the resources to work on it all day because of my situation. If anybody has any clue what's going on I would greatly like to hear from you.
Atlantis167 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2004, 02:55   #2 (permalink)
 
89F150's Avatar
 
Join Date: May 2003
Location: Albury, NSW
Posts: 1,012
Re: '94 Running Rough

Maybe try cleaning the IAC valve. It sits on the side of the throttle body. That might be dirty and be part of the idle problem.
89F150 is offline   Reply With Quote
Old 10-08-2004, 14:11   #3 (permalink)
Atlantis167
 
Join Date: Oct 2004
Location: Ohio
Age: 30
Posts: 4
Re: '94 Running Rough

Thanks 89'. I'll give it a try, and if you think of anything else, I would like to hear.
Atlantis167 is offline   Reply With Quote
Old 10-09-2004, 03:56   #4 (permalink)
 
89F150's Avatar
 
Join Date: May 2003
Location: Albury, NSW
Posts: 1,012
Re: '94 Running Rough

LEt us know how that goes first. MAybe we can go from there then.
89F150 is offline   Reply With Quote
Old 10-10-2004, 10:17   #5 (permalink)
Atlantis167
 
Join Date: Oct 2004
Location: Ohio
Age: 30
Posts: 4
Re: '94 Running Rough

Alright, I finally got a break from school work and went out to the parking garage to take a look at that valve. I'm a redneck so I carry my tools with me to school. The valve looked a little gummed up inside but really not that bad. I cleaned it out as best I could. This weekend I'll be going home so I can maybe test it with a ohm meter. Hopefully I can get an answer from that. Thanks
Atlantis167 is offline   Reply With Quote
Old 10-14-2004, 04:26   #6 (permalink)
 
89F150's Avatar
 
Join Date: May 2003
Location: Albury, NSW
Posts: 1,012
Re: '94 Running Rough

When you cleaned it did it help with the idle or was it still not idling right??
89F150 is offline   Reply With Quote
Old 10-16-2004, 22:31   #7 (permalink)
Atlantis167
 
Join Date: Oct 2004
Location: Ohio
Age: 30
Posts: 4
Re: '94 Running Rough

When I cleaned it, it did not change anything. I finally got a chance to test it and according to Chilton's instructions, it is still working fine. The truck still isn't idling right, or performing right out on the road. It will run fine for a few minutes at idle, then starts cutting out still. Out on the highway, same problem with lack of throttle response. I appreciate your replies and hope you might have some more ideas. Thanks!
Atlantis167 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
XF Falcon running rough at startup YellowXF Inline 6 Tech 14 06-22-2003 04:46
running rough...looks like I'm not the only one... sbcarden General Tech 1 03-08-2003 15:09
Changed plugs and now running rough??? Hinchi General Tech 8 05-15-2002 21:35
rough idle on cpi with new mild cam chargin Inline 6 Tech 2 04-24-2002 23:44
EF with 200k and running Mobil One XR_Strider_GuY General Tech 24 04-15-2002 17:46

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:07.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.