95 F150 needs help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-30-05, 04:52 AM Thread Starter
Registered User
 
Join Date: Mar 2005
Posts: 1
95 F150 needs help

Gentlemen,
I have a somewhat unusual problem. I have a 95 F-150, 5.0 Lt., auto trans. When starting the motor the check engine light flashes 4 times and the idle speeds up momentarily, it will then drop and sometimes nearly stall. The idle is erratic for 30 seconds or so and smooths out and runs fine. This happens at cold start mostly but has happened when warm as well. This past weekend I replaced the throttle body with Ford parts for an unrelated problem. The new throttle body came with a new IAC and TPS, again both new Ford parts. Cleaned EGR and replaced PVC. This has made no change. I am unable to retrieve any codes other that the “system pass “ code. Other than this the engine is running fine, no burning oil, no change in fuel mileage, has good pickup, and no apparent vacuum leaks. I am writing to you today to see if you have any suggestions as to what I may be overlooking or if any of you have had similar experiences. I would like to thank you in advance for any help you may be able to provide.

Tom
mayerst is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome