battery not holding a charge. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-17-2007, 08:52   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 3
battery not holding a charge.

I have a 1999 F150 (4.2l). A couple of days ago my battery died and I replaced with a new one. Then yesterday, I noticed my battery gauge getting lower while driving and the battery lite came on. Then everything went dead. I had it charged but, it is not holding a charge. Can someone tell why this is happening (alternator / regulator or something else) and how I can check to determine what the problem is.

Cheers!
2dusty23 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2007, 11:23   #2 (permalink)
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 43
Posts: 1,486
Re: battery not holding a charge.

Hook a voltmeter to the battery and monitor the voltage while the engine is running. Turn on the lights and blower fan and other electrical items and watch the volts. The vehicle should hold a minimum of 13.6 VDC and if it lower, then it needs an alternator.
Johnny Mullet is offline   Reply With Quote
Old 06-18-2007, 15:58   #3 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 3
Re: battery not holding a charge.

thanks for the info...I'll check it out. The battery must be fully charge to get a proper ready...right! If I get a reading of 13.6 or more am - I guess I will be looking for some other electrical problem?

Cheers !
2dusty23 is offline   Reply With Quote
Old 06-19-2007, 19:14   #4 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,707
Re: battery not holding a charge.

As suggested, check for proper voltage under running condition with multiple accesories on. If voltage is at least 13.6, the alt is doing its job. Make sure your connections are good. Also, just because the battery is new, doesn't mean it is good.
thefonz is offline   Reply With Quote
Old 06-19-2007, 20:45   #5 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 3
Re: battery not holding a charge.

Finally, the battery is fully charged and seems to be holding a charge. However, the battery light is still on - why would this be happening.

thanks for the info...

Cheers!
2dusty23 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.