battery not holding a charge. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-17-07, 08:52 AM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 3
battery not holding a charge.

I have a 1999 F150 (4.2l). A couple of days ago my battery died and I replaced with a new one. Then yesterday, I noticed my battery gauge getting lower while driving and the battery lite came on. Then everything went dead. I had it charged but, it is not holding a charge. Can someone tell why this is happening (alternator / regulator or something else) and how I can check to determine what the problem is.

Cheers!

2dusty23 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-18-07, 11:23 AM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: battery not holding a charge.

Hook a voltmeter to the battery and monitor the voltage while the engine is running. Turn on the lights and blower fan and other electrical items and watch the volts. The vehicle should hold a minimum of 13.6 VDC and if it lower, then it needs an alternator.
Johnny Mullet is offline  
post #3 of 5 (permalink) Old 06-18-07, 03:58 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 3
Re: battery not holding a charge.

thanks for the info...I'll check it out. The battery must be fully charge to get a proper ready...right! If I get a reading of 13.6 or more am - I guess I will be looking for some other electrical problem?

Cheers !
2dusty23 is offline  
post #4 of 5 (permalink) Old 06-19-07, 07:14 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: battery not holding a charge.

As suggested, check for proper voltage under running condition with multiple accesories on. If voltage is at least 13.6, the alt is doing its job. Make sure your connections are good. Also, just because the battery is new, doesn't mean it is good.
thefonz is offline  
post #5 of 5 (permalink) Old 06-19-07, 08:45 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 3
Re: battery not holding a charge.

Finally, the battery is fully charged and seems to be holding a charge. However, the battery light is still on - why would this be happening.

thanks for the info...

Cheers!
2dusty23 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome