F-250 no start keeps blowing #116 fuse - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-20-09, 01:59 PM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 1
F-250 no start keeps blowing #116 fuse

I have a 2004 F-250 with 5.3 gas and the other day it just died. and it keeps blowing the #116 fuse i have no gages it apears to be a dead short? anybody have this problum? thank for any advice Ed

spross86 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-22-09, 01:46 PM
Registered User
 
Join Date: Jun 2009
Posts: 13
Re: F-250 no start keeps blowing #116 fuse

what model is it?
JorG is offline  
post #3 of 3 (permalink) Old 07-23-09, 05:02 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: F-250 no start keeps blowing #116 fuse

Quote:
Originally Posted by JorG View Post
what model is it?
Hmmmm, are your eyes getting as bad as mine?? Seems to be a 2004 F250 with the 5.3
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome