F350 won't crank, battery good, no clicking - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-15-09, 07:58 AM Thread Starter
Registered User
 
Join Date: Jan 2009
Posts: 1
F350 won't crank, battery good, no clicking

The title states most of the facts as I know them. This is a 2003 V10 with low miles. It started 5 minutes earlier, then nothing. What should I look for first? Battery is fine, headlights and interior functions all work. I tried in park and neutral.

tuolumne is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-03-09, 04:27 AM
2005 F-150 crew
 
Join Date: Feb 2009
Age: 45
Posts: 5
Re: F350 won't crank, battery good, no clicking

First check the starter relay by jumping the two large terminals. It should be located somewhere on the passenger side fenderwell. If that doesn't work than you may have a bad starter.
KinkadeIN is offline  
post #3 of 3 (permalink) Old 02-22-09, 12:27 AM
Registered User
 
Join Date: Sep 2008
Posts: 1
Re: F350 won't crank, battery good, no clicking

Yes sir my name is Travis and ill be glad to help you, i had the same problem with my 86 f-150 4x4 it was the alternator just like you said battery was good wouldnt crank and no click well i just bought a new alternator and jumped my truck let run for 10 min, turned it off and next it fired right up.
ChAmPiOn91 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome