Fuel Pump Runs and Runs with ignition off - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-08-2003, 05:05   #1 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Central Washington
Posts: 26
confused Fuel Pump Runs and Runs with ignition off

Son has a 1990 F-150 with a 351, Fuel pump in the rear continues to run after the ignition has been turned off to the point the battery has to be disconnected, other than that the truck runs fine. Anybody have any clues what might be causing this problem? Thanks!
94460 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2003, 06:14   #2 (permalink)
Registered User
 
big1's Avatar
 
Join Date: Mar 2003
Location: Valley Station , Kentucky
Posts: 484
Try checking out the fuel pump relay. I believe you;ll find your problem
__________________
When in doubt :DON'T
Valley Station, Kentucky
Dream EXPression Racing
http://fordexp.freehomepage.com/photo3.html
big1 is offline   Reply With Quote
Old 04-11-2003, 04:38   #3 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Central Washington
Posts: 26
Thumbs up Fixed

Thanks a bunch. The fuel pump relay was changed and fixed the problem.
94460 is offline   Reply With Quote
Old 06-05-2003, 03:22   #4 (permalink)
mikekilo
Guest
 
Posts: n/a
fuel pump keeps running and running

I had the same problem, and yes a fuel pump relay fixed the problem- for a few months-then it started again and continued until the day the tfi module died.Over a year ago and still fine
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No juice @ fuel Pump. 93' Probe GT MikeP General Tech 2 06-13-2003 01:39
Ford see future with fuel cells, trains, 'smart' airbags Stacy94PGT Ford Worldwide News 1 06-07-2003 08:27
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-2002 07:27
New Ford Focus Fuel Cell Vehicle To Tour Europe RPO83 Ford Worldwide News 0 08-28-2002 07:53
Ford uses high-tech means to pursue 25% fuel gain in sport-utility fleet Stacy94PGT Ford Worldwide News 1 07-25-2002 06:24

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:12.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.