Need MAF housing and sensor!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-08-2001, 12:09   #1 (permalink)
Crown Vic Member
 
Join Date: Feb 2001
Posts: 9
Need MAF housing and sensor!!!

If anyone has any spare or take-off MAFs lying around for the 5.4L V8, w/ the part #: XL3Z-12B579-BA , please let me know.
metroplex is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got fairmont cluster what do i need??? AU1SIXA General Tech 7 09-12-2002 05:43
Cooling Fan sensor problems '91 Tempo Mike Pfleger Ford Tempo Forum | Mercury Topaz Forum 0 08-11-2002 06:08
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-2001 13:08
What could be the cause of my temp gauge not working? Chrisbronco Ford Bronco Forum 2 06-27-2001 15:36
Need MAF housing and sensor!!! metroplex Ford Expedition Forum | Lincoln Navigator Forum 0 06-08-2001 12:08

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:53.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.